Partial Outage: Network Services

Incident Report for Berklee IT Services

Monitoring

The ITS networking team has implemented a fix. Wired and wireless network services should return to normal.

ITS will continue monitoring network performance throughout the afternoon.

Technology Service Desk
2238@berklee.edu
Posted Apr 23, 2026 - 12:45 EDT

Identified

The ITS networking team has identified the issue and is investigating workarounds.

ITS will post an update when more information becomes available.

Technology Service Desk
2238@berklee.edu
Posted Apr 23, 2026 - 11:55 EDT

Investigating

We have received reports that internet speeds are slow across campus. Users on campus may experience slowness connecting to external websites. Engineers are investigating.
Posted Apr 23, 2026 - 09:51 EDT
This incident affects: Network Services (Network Services - Boston Campus).