Outage: Confluence

Incident Report for Berklee IT Services

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 12:57 EDT

Investigating

We have received reports of issues with confluence not loading. Technicians are monitoring Atlassian's status page for more information.
Posted Jun 16, 2026 - 09:14 EDT
This incident affected: Confluence.