my.berklee failing to load

Incident Report for Berklee IT Services

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 08:53 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 08, 2026 - 08:52 EDT

Monitoring

Engineers have confirmed the issue has been addressed, and are now monitoring to ensure there are no further issues.

If you continue to have an issue logging in, clear cookies and attempt again.
If that also fails, please open a ticket by emailing 2238@berklee.edu with a screenshot of the error you receive.
Posted Apr 07, 2026 - 18:37 EDT

Identified

We are receiving reports that users are are getting an error "Unable to retrieve course plan" and unable to register.

Engineers are investigating.
Posted Apr 07, 2026 - 15:07 EDT

Monitoring

The service has been restarted, and users should be able to log in and register again. Please close any previously open my.berklee tabs/windows.
If you continue to have an issue logging in, clear cookies and attempt again, and if that fails, please open a ticket by emailing 2238@berklee.edu with a screenshot of the error you receive.
Posted Apr 07, 2026 - 14:49 EDT

Identified

The my.berklee service is being restarted. My.berklee will be unavailable during this time. We will update when this is completed.
Posted Apr 07, 2026 - 14:15 EDT

Investigating

We have received reports that my.berklee is failing to load. Users may be unable to log in, may receive error messages such as "unable to validate single sign on at this time." Engineers are investigating.
Posted Apr 07, 2026 - 13:38 EDT
This incident affected: my.berklee.edu.