Outage: Papercut (Student Printing)

Incident Report for Berklee IT Services

Monitoring

ITS has taken steps to mitigate the issue. We are currently monitoring the service.
Posted Apr 16, 2026 - 10:49 EDT

Identified

We have received reports that some users are unable to print using Papercut and receiving various error messages. Users may erroneously be prompted to associate their card, the printer may produce an "internal error" message, or "unable to connect to server."
Engineers are investigating.
Posted Apr 13, 2026 - 16:13 EDT
This incident affects: Papercut.