Partial Outage: Canvas

Incident Report for Berklee IT Services

Identified

Technicians have reversed the changes that made classes unavailable to users. Users should be able to see enrolled classes again. Investigation is continuing to identify root cause.

Users still unable to view classes should log out and back in to canvas.berklee.edu to refresh. If the issue continues, please create a ticket with 2238@berklee.edu.
Posted Sep 04, 2026 - 14:44 EDT

Investigating

We have received reports that classes on canvas are no longer available on users' dashboards. This is affecting both students and faculty. Technicians are investigating.
Posted Sep 04, 2026 - 13:49 EDT
This incident affects: Canvas.