PowerFaids Maintenance

Incident Report for Berklee IT Services

Resolved

Successfully updated production PowerFAIDS with BUID (Berklee Universal ID).
Posted Jun 18, 2026 - 20:23 EDT

Update

Maintenance is still ongoing. Expected completion time: 12:00PM Boston time
Posted Jun 18, 2026 - 11:38 EDT

Identified

Powerfaids maintenance is still in process: https://status.berklee.edu/incidents/6mq4pq8c9cvc

Expected completion time: 11:30AM Boston
Posted Jun 18, 2026 - 11:17 EDT
This incident affected: PowerFAIDS.