24TF Network connectivity for wired and wireless are down

Incident Report for Berklee IT Services

Postmortem

The power circuit tripped. The electrician turned it back on and network connectivity was restored.

Posted Aug 23, 2025 - 14:17 EDT

Resolved

This incident has been resolved.
Posted Aug 23, 2025 - 14:14 EDT

Investigating

We are currently investigating this issue.
Posted Aug 23, 2025 - 10:19 EDT
This incident affected: Network Services (Network Services - Boston Campus).