Canvas outage

Incident Report for Berklee IT Services

Monitoring

Instructure has restored our Canvas instance, and ITS is currently monitoring the service for stability.

Technology Service Desk
2238@berklee.edu
Posted May 08, 2026 - 06:19 EDT

Update

Instructure, our vendor, has reported a Canvas outage that is affecting users globally.

Berklee will continue to monitor the situation and provide updates as necessary.

Technology Service Desk
2238@berklee.edu
Posted May 07, 2026 - 17:06 EDT

Identified

Our Canvas site is currently down and inaccessible.

ITS has reached out to our vendor, Instructure, to resolve the issue. In the meantime:

1. Share the information with your teams.
2. Stay informed by checking for updates on our Statuspage and https://status.instructure.com.

We will post further notifications when the situation changes.

Technology Service Desk
2238@berklee.edu
Posted May 07, 2026 - 16:53 EDT
This incident affects: Canvas.