Kaltura - Degraded Performance

Incident Report for Berklee IT Services

Identified

The issue has been identified and once a fix has been implemented, we will update this incident.
Posted Oct 21, 2025 - 11:59 EDT

Investigating

Kaltura has been intermittently missing pushes of Zoom Recordings since late July, 2025. As always, all recorded meetings within 10 mos. are still available in Zoom.
Posted Oct 21, 2025 - 11:53 EDT
This incident affects: Digital Storage.