my.berklee Degraded Performance

Incident Report for Berklee IT Services

Monitoring

The slowness and loading issues in my.berklee.edu have improved and the team will continue to monitor the system.
Posted Nov 14, 2025 - 15:50 EST

Update

My.berklee.edu will unavailable for 15 mins due to emergency maintenance. We are working with our external vendor to help resolve the slowness and loading issues in My.Berklee.
Posted Nov 14, 2025 - 14:39 EST

Update

Engineers are investigating. We are in working with our external vendor to help troubleshoot and resolve the slowness issues and failure to load in My.Berklee.
Posted Nov 14, 2025 - 13:31 EST

Identified

We have received reports that there is a problem with my.berklee, and it is affecting users of my.berklee. Users are reporting that pages fail to load or get stuck on "loading my data."
Engineers are investigating.
Posted Nov 14, 2025 - 11:50 EST

Monitoring

The slowness and loading issues in my.berklee.edu have been resolved and the team will continue to monitor the system.
Posted Nov 13, 2025 - 16:39 EST

Update

We are in working with our external vendor to help troubleshoot and resolve the slowness issues and failure to load in My.Berklee.
Posted Nov 13, 2025 - 14:22 EST

Identified

We are in contact with our external vendor to help resolve the slowness issues and failure to load in My.Berklee.
Posted Nov 13, 2025 - 13:22 EST

Investigating

We have received reports that there is a problem with my.berklee, and it is affecting all users of my.berklee. Users are reporting that pages fail to load or get stuck on "loading my data."
Engineers are investigating.
Posted Nov 13, 2025 - 12:45 EST
This incident affects: my.berklee.edu.