Service Disruption: Google Workspace

Incident Report for Berklee IT Services

Resolved

Google resolved the incident at 5:00 pm EDT on 6/12/2025.
Posted Jun 13, 2025 - 16:28 EDT

Identified

Google as reported a known issue with their Google Workspace and other services. Service may be slow or interrupted until it is resolved.
You can monitor their updates directly here: https://www.google.com/appsstatus/dashboard/incidents/Eab7zGLWSaUJyh9c9R9L
Posted Jun 12, 2025 - 15:06 EDT
This incident affected: Google (Google Mail, Google Calendar, Google Drive).