Jira: Automation Rule execution is delayed

Incident Report for Berklee IT Services

Resolved

Jira reports this is resolved.
Posted Apr 24, 2025 - 08:57 EDT

Identified

Jira is investigating cases of degraded performance for automation rules for Confluence and Jira Service Management which may cause an automations be delayed, preventing their execution.

Jira's status can be monitored directly here: https://jira-software.status.atlassian.com
Posted Apr 23, 2025 - 11:14 EDT
This incident affected: ITS Tickets Database (Jira).