Slowness on Canvas

Incident Report for Berklee IT Services

Resolved

Page load times have returned to normal and users no longer receive timeout errors when accessing Canvas. Functionality has returned to normal.
Posted Nov 07, 2025 - 14:25 EST

Update

Our vendor has implemented a fix and is actively monitoring the issue.
Posted Nov 07, 2025 - 12:03 EST

Investigating

Some users may experience slowness, long page load times, or 504 timeout errors when accessing Canvas. Our vendor is currently investigating the issue.
Posted Nov 07, 2025 - 11:51 EST
This incident affected: Canvas.