Error with XENS page in Colleague

Incident Report for Berklee IT Services

Postmortem

Resolution: Ferrilli discovered the issue was related to permissions on the LDM.GUID file. This issue was related to file maintenance that was done the previous evening by Ferrilli - Sept. 4th at 10pm ET. The issue was affecting Colleague mnemonics other than XENS.

Going forward, whenever file maintenance is performed for LDM.GUID, Ferrilli will need to check permissions on that file and make sure there is write and execute access for the LDM.GUID file.

Ferrilli consultant made the permission changes to the LDM.GUID file in Production and that resolved the issue.

Posted Sep 05, 2025 - 13:43 EDT

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 13:41 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2025 - 10:19 EDT

Identified

ITS has received tickets this morning regarding issues with Colleague XENS. Users may see an error message that prevent using the page that is labeled "A program or data error has been detected!" followed by technical data.

The error messages seem to be related to work done on the Colleague GUID files last evening. We are engaging an external vendor to assist with resolution.
Posted Sep 05, 2025 - 09:29 EDT
This incident affected: Colleague.