Berklee Software outage

Incident Report for Berklee IT Services

Resolved

Our vendor, Jamf, has notified us that the earlier issue affecting the Berklee Software App on Macs has been resolved. You should now be able to download and update software through the app as normal.

Thank you for your patience and understanding.

Technology Service Desk
2238@berklee.edu
Posted Feb 25, 2026 - 15:22 EST

Identified

Our vendor, Jamf, has identified the issue and is implementing a workaround.

We will post an update when we have more information.

Technology Service Desk
2238@berklee.edu
Posted Feb 25, 2026 - 12:24 EST

Investigating

We have received reports of a problem with the Berklee Software app affecting all Berklee-issued Mac computers. Issues being reported include not being able to download any applications:

ITS is doing preliminary investigations and contacting our vendor, Jamf. We will post an update when we have more information.

Technology Service Desk
2238@berklee.edu
Posted Feb 25, 2026 - 11:20 EST
This incident affected: Berklee Software App.