Outage: Workday reporting log in failures and slowness

Incident Report for Berklee IT Services

Resolved

Workday reports the issue is resolved, users should be able to log in again.
Posted Mar 18, 2025 - 08:42 EDT

Identified

We have received reports of users unable to log in to Workday, which is being also being reported by users outside Berklee. Users may be unable to log in, and those already logged in may see significant slowness.

We have opened a ticket with Workday for further support.
Posted Mar 17, 2025 - 14:47 EDT
This incident affected: Workday.