Potential Errors with Google Workspace Services

Incident Report for Berklee IT Services

Resolved

Google reports issue resolved.
Posted Mar 13, 2026 - 11:19 EDT

Investigating

Google is reporting possible increased errors with its services. Users can monitor Google's status for this incident here: https://www.google.com/appsstatus/dashboard/incidents/KamjizntSiNtRETcBL2Q
Posted Mar 13, 2026 - 10:19 EDT
This incident affected: Google (Google Mail, Google Calendar, Google Drive).