Partial Outage: Some student unable to access Microsoft Office

Incident Report for Berklee IT Services

Resolved

There is a workaround in place. Please contact 2238@berklee.edu if your Office installation is affected
Posted Jul 08, 2026 - 09:54 EDT

Identified

We have identified the issue and are working on a solution. Affected users should email 2238@berklee.edu in the interim for troubleshooting.
Posted Jun 18, 2026 - 11:10 EDT

Investigating

We are receiving reports that some students are unable to access Microsoft Office. Users may experience error messages that documents are "view only" and when they attempt to log in to office, it fails. When logging in to office.com, users may receive an error message "we couldn't find that Microsoft account."
Posted Jun 03, 2026 - 12:30 EDT
This incident affected: Microsoft Office.