VPN and MyBerklee Connectivity issues (Comcast Xfinity users)

Incident Report for Berklee IT Services

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 16:59 EDT

Monitoring

ITS has received reports that My Berklee and VPN are accessible from Comcast (Xfinity) and Crowncastle networks.

ITS will continue to monitor service throughout the day

Technology Service Desk
2238@berklee.edu
Posted Apr 29, 2026 - 11:05 EDT

Identified

The network team has identified an issue where network traffic coming from Comcast (Xfinity) and Crowncastle is not connecting properly to the Berklee network.

Any users attempting to connect to services that are hosted on the Berklee Boston campus (e.g., VPN and MyBerklee) from either of these networks are experiencing connectivity issues.

ITS is contacting these providers and will post an update when more information becomes available.

Technology Service Desk
2238@berklee.edu
Posted Apr 29, 2026 - 10:27 EDT

Update

We are continuing to investigate this issue.
Posted Apr 29, 2026 - 09:40 EDT

Investigating

We have received reports that there is a problem with the VPN service, and it is affecting users connecting from off-campus. Issues being reported include:

After authenticating successfully, users receive the error "Connection Attempt has timed out. Please verify internet connectivity."

ITS is doing preliminary investigations and will post an update when we know more.

Technology Service Desk
2238@berklee.edu
Posted Apr 29, 2026 - 09:38 EDT
This incident affected: VPN Service, my.berklee.edu, and Secure File Exchange.