My.Berklee not displaying class locations for some users

Incident Report for Berklee IT Services

Resolved

ITS was able to implement a fix yesterday at 3:30 pm and has been monitoring Colleague and MyBerklee since then. This issue has now been resolved.

Thank you for your patience and understanding while we investigated and fixed this issue.

Technology Service Desk
2238@berklee.edu
Posted Sep 03, 2025 - 11:53 EDT

Identified

ITS has identified an issue with my.berklee not displaying class locations properly.
As a workaround, students can get the section location details from the calendar view on My.Berklee by selecting an individual class.
Posted Sep 02, 2025 - 10:29 EDT
This incident affected: my.berklee.edu.