Network Outage at Saint Cecilia

Incident Report for Berklee IT Services

Resolved

This incident has been resolved. network connectivity in Saint Cecilia is fully restored.
Posted Mar 25, 2026 - 14:56 EDT

Identified

We've identified that one of the point to point radio links, which serves as the network backbone for St. Cecilia, is malfunctioning. We are currently working to come up with a solution, but do not have an ETA at this time.
Posted Mar 24, 2026 - 14:16 EDT

Investigating

We have identified a network switch outage at Saint C. which is affecting both the wired and wireless in that build. We are currently investigating.
Posted Mar 24, 2026 - 09:37 EDT
This incident affected: Network Services (Network Services - Boston Campus).