Network maintenance: Boston Campus - 150 Mass Ave, Residential floors

Scheduled for Nov 19, 06:00 - 09:00 EST

Update

This maintenance window has been updated to include all three residential floors in 150 Mass Ave.

The new window is 6 hours long, starting at 6:00 am EST on Wednesday, November 20th, 2025.

During this time, residents on the 4th, 5th, and 6th floors of 150 Mass Ave may experience intermittent disruptions to wired and wireless network services.

Further notifications will be posted when the maintenance is completed.

Technology Service Desk
2238@berklee.edu
Posted Nov 17, 2025 - 10:30 EST

Scheduled

Please be aware that necessary maintenance to network services in 150 Mass Ave is scheduled to be performed by ITS on Wednesday, November 19th, 2025, at 6:00 AM EST for 3 hours.

During this time, residents on the 5th floor of 150 Mass Ave may experience intermittent disruptions to wired and wireless network services.

Further notifications will be posted when the maintenance is completed.

Technology Service Desk
2238@berklee.edu
Posted Nov 16, 2025 - 17:52 EST
This scheduled maintenance affects: Network Services (Network Services - Boston Campus).