Jira Reporting Degradation of Service

Incident Report for Berklee IT Services

Resolved

Atlassian reports issue resolved.
Posted May 21, 2025 - 08:43 EDT

Update

Posted May 20, 2025 - 10:20 EDT

Investigating

Jira is investigating cases of degraded performance for all instances of Jira Service Management, Jira Service Management Email Requests, Authentication and User Management, Automation for Jira, among others.
Posted May 20, 2025 - 10:19 EDT
This incident affected: ITS Tickets Database (Jira).