Berklee Drive Service (https://berkleedrive.berklee.edu/) Has Been Restored

Incident Report for Berklee IT Services

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 21:39 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2025 - 15:18 EDT

Update

There appears to be a back-end database issue which is preventing access to BerkleeDrive. Details will be provided as we obtain them, as well as anticipated recovery time.
Posted Jun 30, 2025 - 09:44 EDT

Investigating

We are currently investigating this issue.
Posted Jun 30, 2025 - 09:23 EDT
This incident affected: Berklee Software App.