Network Outage at Saint Cecilia

Incident Report for Berklee IT Services

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 15:03 EST

Identified

We are currently working to resolve a network outage at Saint Cecila. This is affecting the wired and wireless network at that location. We expect to have it resolved shortly.
Posted Mar 05, 2026 - 14:59 EST
This incident affected: Network Services (Network Services - Boston Campus).